COAWST compilation error when coupling ROMS with other models

Discussion on computers, ROMS installation and compiling

Moderators: arango, robertson

Post Reply
Message
Author
shestakova.aa.92
Posts: 2
Joined: Mon Oct 25, 2021 1:00 pm
Location: Obukhov Institute of Atmospheric Physics

COAWST compilation error when coupling ROMS with other models

#1 Post by shestakova.aa.92 »

I am a COAWST user. I have successfully compiled and run different WRF+SWAN applications.
However, now I am stuck on the adding of the ROMS model.
When compiling WRF+SWAN+ROMS applications (my own as well as SANDY and JOE_TC) I have the following error:

Code: Select all

ocean_coupler.f90:1969:46:

      &                          OCN_COMM_WORLD)
                                              1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
ocean_coupler.f90:1729:46:

      &                          OCN_COMM_WORLD)
                                              1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
ocean_coupler.f90:1545:42:

      &                      OCN_COMM_WORLD, Router_A(ng,ia)%ROMStoWRF)
                                          1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
ocean_coupler.f90:1402:40:

       CALL mpi_comm_rank (OCN_COMM_WORLD, MyRank, MyError)
                                        1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
ocean_coupler.f90:935:26:

      &      OCN_COMM_WORLD)
                          1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
ocean_coupler.f90:596:26:

      &      OCN_COMM_WORLD)
                          1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type
ocean_coupler.f90:405:42:

      &                      OCN_COMM_WORLD, Router_W(ng,iw)%ROMStoSWAN)
                                          1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
ocean_coupler.f90:186:55:

         CALL MCTWorld_init (N_mctmodels, MPI_COMM_WORLD,                &
                                                       1
Error: Symbol ‘mpi_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
ocean_coupler.f90:174:40:

       CALL mpi_comm_rank (OCN_COMM_WORLD, MyRank, MyError)
                                        1
Error: Symbol ‘ocn_comm_world’ at (1) has no IMPLICIT type; did you mean ‘atm_comm_world’?
make: *** [Master/Module.mk:25: Build/ocean_coupler.o] Error 1 
There were no other errors during compilation.

When compiling ROMS-only application, compilation succeeds.

What can be the reason of this error? It could be an mpi-related error, but why then SWAN+WRF were successfully coupled?

I have gfortran compiler v 3.8.0 and openMPI v 4.1.0. My compiler file and coawst.bash are attached.

--Anna
Attachments
Linux-gfortran.mk
(15.48 KiB) Downloaded 12 times
coawst.bash
(20.87 KiB) Downloaded 12 times

jcwarner
Posts: 1001
Joined: Wed Dec 31, 2003 6:16 pm
Location: USGS, USA

Re: COAWST compilation error when coupling ROMS with other models

#2 Post by jcwarner »

can you post the entire output of the build? there might have been something earlier.
and can you create a new post for this issue here:
https://github.com/jcwarner-usgs/COAWST/issues

thanks,
john

shestakova.aa.92
Posts: 2
Joined: Mon Oct 25, 2021 1:00 pm
Location: Obukhov Institute of Atmospheric Physics

Re: COAWST compilation error when coupling ROMS with other models

#3 Post by shestakova.aa.92 »

Thank you for the reply. Here is the full output of the build.
Attachments
log.txt
(1.4 MiB) Downloaded 9 times

Post Reply